[Solved] Chameleon - issue with jboss home

Hi guys,

i’m trying to use a custom chamelon containers.yaml file which is a copy of the default one where I only changed gav, you can see it here.

I’ve got the error below:

org.jboss.arquillian.container.spi.ConfigurationException: jbossHome ‘C:projetossoewstargetserverjboss-eap-dist_6.3.4.Final.jboss-eap-dist-6.3.4.Final’ must exist
at org.jboss.arquillian.container.spi.client.deployment.Validate.configurationDirectoryExists(Validate.java:139)
at org.jboss.as.arquillian.container.DistributionContainerConfiguration.validate(DistributionContainerConfiguration.java:103)

here is my arquillian.xml:

<container qualifier="chameleon" default="true">
			<property name="chameleonTarget">jboss:6.3.4.Final:${arquillian.containerMode}</property>
			<property name="chameleonContainerConfigurationFile">/containers.yaml</property>    

I need to use target folder so I can run on CI where i don’t have privileges to create folders.

I see in the containers.yaml use a ${dist} property for jbossHome but I have no idea how to set this value.

hmm ${dist} comes from the own .yaml file…I think the issue is with windows here, because the slashes are being ommited. Will test at home to see how it goes.

${dist} in the yaml file is just a expression to tell chameleon to replace that value with the location of the extracted/downloaded distribution artifact if jbossHome is not set by the user and if the adapter is either managed or embedded and require a dist to run.

Yea, it looks like it’s loosing the path separator for some reason. Not personally tested this on windows.

The relevant code is here: https://github.com/arquillian/arquillian-container-chameleon/blob/master/src/main/java/org/arquillian/container/chameleon/controller/DistributionController.java#L66

Solved by this issue and released as part of Alpha4: